Upgrade existing project to the latest version of UVDesk


  • UVdesk Staff

    Let me know how can i upgrade the uvdesk to latest version


  • UVdesk Staff mod

    If you want to update your old version to latest one.

    You need to update all dependent bundle of this project by running below commands.

    composer update uvdesk/core-framework

    composer update uvdesk/support-center-bundle

    composer update uvdesk/mailbox-component

    composer update uvdesk/automation-bundle

    composer update uvdesk/extension-framework

    Note:  Before running above command take a backup of swiftmailer.yaml, uvdesk_mailbox.yaml,  uvdesk.yaml (you will find these file under config->packages of your project)

    If you don't want to set your site_url, swiftmailer and mailbox again.

    OR

    You can simply create a new project by this command it will always install the latest version of project:

    composer create-project uvdesk/community-skeleton helpdesk-project



  • @Sanjeev Can you please describe the update process step by step not using the composer. There is an issue currently with the composer install as it fails when .env is changed to production - known issue for months. I tried simply updating using your zip by doing clean install and then moving the 3 files you mentioned above with the composer update - but for example profile photos are gone? To recap - can you please describe update process with zip downloaded from your website to make sure all settings and other assets are kept? Thanks


  • UVdesk Staff mod

    @slawn

    You can download project zip form here and and can setup After Unzip.

    All the issues fixes and updates(new added features) are there with this zip till now.



  • @Sanjeev Thanks for replying, but I'm asking about the upgrade process itself to keep the current settings intact. Like I said I upgraded by simply installing it again - but then noticed that all the attachments are gone, all profile images are missing etc.

    If you could explain what directories are sensitive in a sense that I need to move them from old installation to the new installation in order to have all settings, old files etc still working correctly. If you could explain for example the upgrade process should be

    1. Download latest version and install
    2. From old installation move the following files to keep the settings: swiftmailer.yaml, uvdesk_mailbox.yaml, uvdesk.yaml
    3. From old installation move the public/assets directory to the new installation to keep user profile photos and attachements

    Etc. I simply don't know where all the settings and files are stored - if I missed anything. Thanks


  • UVdesk Staff mod

    @slawn
    Currently you can do this using https://forums.uvdesk.com/topic/1822/upgrade-existing-project-to-the-latest-version-of-uvdesk/2

    As In current release there is a problem to switching the environment if you have created project using composer command (already fix but will reflect from next release ) but it is fixed for zip.

    But will recommend to setup project using zip which we have provided you in previous reply and it is updated to till date.



  • @Sanjeev but what if I don't want to use composer for upgrading - let's say I have composer 2 which is not compatible. You are still not explaining to me how to upgrade the software by hand from the ZIP and keep all the settings and attachments. Why can't you just explain - like unzip the package, upload everything to the server, copy this and that from old installation in order to keep everything in order?? Please forget about composer - like it doesn't exist - how should I upgrade current install using ZIP and not loosing anything / any data or settings? Can you describe the process or at least give a list of all the files and directories that store some data that should be moved. Thanks


  • mod admin

    @slawn I agree with you. I'm also unable to update uvdesk with the instruction given by @Sanjeev as is possible to see in the Google ReCaptcha discussion.

    I'm now trying to do what composer will do but without composer because UVdesk never support Composer 2 and I cannot use an inferior composer version.

    I will try to manually replace this folder after done the backup of the described files.
    Will see if work and I will try to update you here.


  • mod admin

    @Sanjeev the update is not working on my side so something is wrong.
    What I do to update:

    As I cannot use composer because the version 2 is not supported by UVdesk i download the zip file mentioned by you.
    In my server I renamed uvdesk folder under the vendor folder to uvdesk_old than i uploaded the uvdesk inside vendor of your zip file.

    I don't need replace the files present in config >> packages as is not replaced if I don't use composer and in your instruction @Sanjeev you never mention to replace that files.

    So I only replaced uvdesk in vendor folder.
    Load my project and I see a blank white page.

    Server error log have to say:

    AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Symfony\\Component\\Debug\\Exception\\FatalThrowableError: Too few arguments to function Webkul\\UVDesk\\CoreFrameworkBundle\\Dashboard\\SearchTemplate::__construct(), 1 passed in /uvdesk/var/cache/prod/ContainerWSHmTL2/srcApp_KernelProdContainer.php on line 771 and exactly 3 expected in /uvdesk/vendor/uvdesk/core-framework/Dashboard/SearchTemplate.php:16\nStack trace:\n#0 /uvdesk/var/cache/prod/ContainerWSHmTL2/srcApp_KernelProdContainer.php(771): Webkul\\UVDesk\\CoreFrameworkBundle\\Dashboard\\SearchTemplate->__construct(Object(Twig\\Environment))\n#1 /uvdesk/var/cache/prod/ContainerWSHmTL2/srcApp_KernelProdContainer.php(654): ContainerWSHmTL2\\srcApp_KernelProdContainer->getUvdesk_ExtensiblesService()\n#2 /uvdesk/var/cache/prod/Container...',
    

    After php bin/console c:c I can see the help desk but I'm unable to login. The error is: Authentication request could not be processed due to a system problem.

    Well I opened a ticket as explained here. I'm sharing more issue details so maybe can figure out what is wrong.


  • mod admin

    @slawn
    Not only public/assets but the full public folder need to be replaced as mentioned here


Log in to reply