@trkaushik put /index.php at the end of URL after public and check if it works. Also try below method. Open your .htaccess file under public folder of your project and add some random text at the top and save your file. Now try to access your project. Case 1: If you are getting 500 Internal server error after adding a random text in .htaccess file. It means it is working. Case 2: If you are still able to access public path of project which means  .htaccess it is not working yet. so you need to enable it. Open your apache2.conf file and Allow overwrite All. <Directory /home/users/www> Options Indexes FollowSymLinks AllowOverride All Require all granted here. Now also you need to run two below commands for enabling mod rewrite rule. a2enmod rewrite service apache2 restart