uvdesk no emails are received



  • Hallo,
    my problem is I setup Swiftmailer and Mailbox. I added one TestClient (myself) when I try to press Forgot Password, it tells please check mail. but No mail was received.

    Also no other mails are received

    swiftmailer.yaml

    swiftmailer:
        default_mailer: mailer_3622
        mailers:
            mailer_3622:
                transport: smtp
                username: support@izon.ml
                password: *******************
                host: mail.izon.ml
                port: 465
                encryption: ssl
                auth_mode: login
                sender_address: 
                delivery_addresses: ['']
                disable_delivery: false
            mailer_9140:
                transport: smtp
                username: helpdesk@izon.ml
                password: *************
                host: mail.izon.ml
                port: 465
                encryption: ssl
                auth_mode: login
                sender_address: 
                delivery_addresses: ['']
                disable_delivery: false
            mailer_4594:
                transport: smtp
                username: *****@gmx.net
                password: *******************
                host: mail.gmx.net
                port: 587
                encryption: tls
                auth_mode: login
                sender_address: *****@gmx.net
                delivery_addresses: ['']
                disable_delivery: false
    
    

    uvdesk_mailboxes.yaml

    uvdesk_mailbox:
        emails: ~
            # Often Reply emails like from gmail contains extra and redundant previous mail data.
            # This data can be removed by adding delimiter i.e. specific line before each reply. 
            # delimiter: '<-- Please add content above this line -->'
            # enable_delimiter: true
        
        # Configure your mailboxes here
        mailboxes:
            HelpDesk:
                name: Izon Help Desk
                enabled: true
    
                # [SMTP] Outgoing mail server
                # Swiftmailer smtp mailer to use for sending emails through on behalf of this mailbox
                smtp_server: 
                    mailer_id: mailer_9140
    
                # [IMAP] Incoming mail server
                # IMAP configurations to use for fetching emails from mailbox
                imap_server:
                    host: '{mail.izon.ml:993/imap/ssl}INBOX'
                    username: helpdesk@izon.ml
                    password: *****
    
    

    uvdesk.yaml

    parameters:
        app_locales: en|fr|it
        
        # Default Assets
        assets_default_agent_profile_image_path: 'bundles/uvdeskcoreframework/images/uv-avatar-batman.png'
        assets_default_customer_profile_image_path: 'bundles/uvdeskcoreframework/images/uv-avatar-ironman.png'
        assets_default_helpdesk_profile_image_path: 'bundles/uvdeskcoreframework/images/uv-avatar-uvdesk.png'
    
        uvdesk_site_path.member_prefix: member
        uvdesk_site_path.knowledgebase_customer_prefix: customer
        
        # File uploads constraints
        # @TODO: Set these parameters via compilers
        max_post_size: 8388608
        max_file_uploads: 20
        upload_max_filesize: 2097152
    
    uvdesk:
        site_url: 'localhost:80/public_html/support/public'
        upload_manager:
            id: Webkul\UVDesk\CoreFrameworkBundle\FileSystem\UploadManagers\Localhost
        
        support_email:
            id: helpdesk@izon.ml
            name: UVDesk Community
            mailer_id: mailer_9140
        
        # Default resources
        default:
            ticket:
                type: support
                status: open
                priority: low
            templates:
                email: mail.html.twig
    
    

    Greetings


  • UVdesk Staff mod

    @SeppyUV

    Locate the file vendor->uvdesk->core-framework->Services->EmailService.php.

    Open the EmailService.php reach to sendMail() function.

    and dump() the exception as in attached images.

    4c9f3aa9-c88e-4350-8b67-5e7d2dd7c268-image.png

    5f7f7fe9-147f-4329-91f0-1f41f03c5d54-image.png

    It will show the error you are facing while sending mails (if adding an agent, creating a ticket etc).

    Other helpful link:
    https://forums.uvdesk.com/topic/1870/how-to-debug-the-error


Log in to reply