Installation issues



  • Good Evening,

    I'm trying to install UVDesk on our server to test it but running into installation issues.

    If I install it with composer, it will work and I can get onto the set up scree and enter all of the database information, and then it takes me to an option to either go to the admin panel, which if I attempt I get an "Variable "user_service" does not exist", and if I try to go to the Knowledgebase I get an "Call to a member function getName() on null" error from Symphony.

    While installing it with composer, I did receive error messages while it was configuring uvdesk/api-bundle there were two fatal PHP errors:

    • Configuring uvdesk/core-framework
      PHP Fatal error: Uncaught Error: Call to undefined method Symfony\Component\Yaml\Yaml::parseFile() in /data/www/live/helpdesk-project/vendor/uvdesk/composer-plugin/lib/Composer/ComposerPackage.php:125

    Fatal error: Uncaught Error: Call to undefined method Symfony\Component\Yaml\Yaml::parseFile() in /data/www/live/helpdesk-project/vendor/uvdesk/composer-plugin/lib/Composer/ComposerPackage.php:125

    I'm using PHP 7.4 on the main server. It is an Amazon EC2 instance running Amazon Linux. I tried it on another EC2 server I run which is running PHP 7.2, and I received the same composer error messages, but I couldn't get to the set up screen because I can't install php-imap on the 7.2 server.

    I also tried installing it from the zip file. However, I receive an error that the installation is unable to connect to the database. I updated the .env file to match what was in the composer installation, and I was able to get to the main screen, but the credentials to log in would not work. So then I tried to copy the /config file from the composer folder the folder I created with the zip installation, and that didn't work either, as I'm getting an error that says: "Attempted to load class "UVDeskApiBundle" from namespace "Webkul\UVDesk\ApiBundle". Did you forget a "use" statement for another namespace?"

    For some the forgot password link isn't working either on the new installation from the Zip file either, so I can't see if I can log in there.

    Any suggestions?

    Thanks!


  • UVdesk Staff mod

    @Curtisf
    Try using php version 7.2 or 7.3.

    Check below link and make a try.
    https://github.com/uvdesk/community-skeleton/issues/290#issuecomment-661113642



  • Using the database you suggested within the PHP 7.4 installation worked.

    Thank you for your help, I look forward to playing with it.


  • UVdesk Staff mod

    @Curtisf

    Glad to know that you issue has been resolved.


  • UVdesk Staff mod

    @Curtisf

    Stay tuned with us you will get many updates and issue resolved in next release of project.

    https://github.com/uvdesk/community-skeleton

    Watch project repository here.


Log in to reply