Debian Installtion Problem



  • Hi,

    I've looking at moving to a shared solution like this and on initial testing this looks fantastic!

    I'm trying to install it on my dedicated Debian 9.1.3 machine with PHP 7.4.

    First of all is this possible?

    I am hitting an immediate problem with this on stage 1 System Requirements I get:

    Unable to locate the path on the server.
    Try putting index.php after your helpdesk installation's site url or If you are using apache, make sure that mode_rewrite module is enabled and AllowOverride directive for document root is set to All/FileInfo in your server's configuration file.

    I assume this is referring to mod_rewrite?

    As far as I can see mod_rewrite is activated - when I run a2enmod rewrite i get "Module rewrite already enabled"

    Do I need to make some change to my .htaccess as well/remove my .htaccess?

    What does the AllowOverride change above mean - change it to either All or FileInfo?

    Any help greatly appreciated!



  • @easyuvdesk

    In case of Apache:

    Open your .htaccess file under public folder of your project and add some random text at the top and save your file.

    Now try to access your project.

    Case 1:

    If you are getting 500 Internal server error after adding a random text in .htaccess file.

    It means it is working.

    Case 2:

    If you are still able to access public path of project which means  .htaccess it is not working yet.

    so you need to enable it.

    Open your apache2.conf file and Allow overwrite All.

    <Directory /home/users/www>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted

    here.

    Now also you need to run two below commands for enabling mod rewrite rule.

    a2enmod rewrite
    service apache2 restart





  • @Sanjeev said in Debian Installtion Problem:

    <Directory /home/users/www>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted

    I'm trying the ubuntu test server now by the way.

    I have tested .htaccess in the top public_html/ directory and it is working and is now empty.

    I have then entered:
    <Directory /home/uvdeasypay/public_html>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    in my apache2.conf and still have the same issue?

    it also still needs the index.php adding to the server installation address in the browser.

    Any more thoughts?



  • @easyuvdesk

    Have you restart the server after making changes.

    Also try below method if unable to do by above.

    https://github.com/uvdesk/community-skeleton/issues/290#issuecomment-661113642


Log in to reply