Problem in the Php Mailbox



  • Screenshot (117).png And this is the warning I'm getting.



  • imap_open() warning is showing here because of two reason

    1. you entered the wrong Gmail password during the setup mailbox.
      to check your Gmail password which you entered during setup mailbox.
      open uvdesk_mailbox.yaml file & check here your mailbox setup password is
      correct or not .
    file location  : your_project_name->config->packages->uvdesk_mailbox.yaml
    
    1. In your Gmail account Less secure app permission is not enabled.
      If less secure permission is not enabled on your Gmail account please follow this link .

    After this, you can fetch mails by hit the refresh command.

    If you still get the same issue or any issue please let us know.



  • Hi,

    @gulzarahmad is the engineer currently trying to assist me with getting the mailbox/swift mailer working on the VPS community install.

    After enabling less secure apps the mailbox is now fetching correctly from Gmail, however, this is not useful as I have a company domain with associated IMAP mailboxes that still do not work.

    The IMAP server details are correct (although the mailbox config does not allow for port configuration so I can only assume its using 993 or 143 to fetch) I have tested the credentials using the providers webmail portal and they work perfectly fine on another rainloop webmail instance using the incoming/outgoing server details.

    There is no useful output on the failure to fetch, simply;

    27d4f68e-057c-46b1-b508-ebcaa94583a9-image.png

    But the mailbox does exist!

    b8906edd-3e6e-4caf-8a1c-dd1e2eff8208-image.png

    ad139e01-1161-4027-bd7b-2dc99cd417f9-image.png

    uvdesk_mailbox.yaml shows the correct password, although doesn't show port number or SSL enabled for the corporate IMAP account, should this be added manually?



  • 2930b498-e814-4990-86e2-03945a175ee0-image.png



  • @leedsy90 @gulzarahmad
    I think this your host problem.
    Screenshot_75.png
    '{imap.public-internet.co.uk:993/imap/ssl}INBOX'
    I think this will work for you

    If you still getting the same issue, Please let us know.



  • Okay so I don't know whats changed, other than setting the swift mailer to use port 25 with no SSL, but now I get a different error:

    9f5320bd-82fc-4a5a-92dc-54ce58d4aec7-image.png

    Again it cannot be the password as I've logged into this mailbox in two separate webmail clients.



  • OMG! @vipin you are an absolute genius! Editing the uvdesk_mailbox.yaml and adding the '{imap.public-internet.co.uk:993/imap/ssl}INBOX' string worked!



  • 2fe9f3c8-fcfe-4526-be81-6505fd54625a-image.png



  • @leedsy90
    I am happy to see that your problem is now resolved.

    If you get any issues, Please let us know.



  • @vipin Thank you so much for your Help.


Log in to reply