Issue installing UVdesk 1.0.16 using docker-compose


  • mod admin

    @ericastillo I'm creating this topic for you after our chat conversation (ID - 137).

    I see you are having issue since different weeks about creating a new UVdesk instance using docker-compose in your local test PC.

    Also if database info seems are correct, the wizard is unable to connect.
    You wrote "If you notice the container does not finish".
    Also "I do not know if that is the problem. or I do not know if for docker-compose so be it.
    Do you have any uvdesk dockerfile that works for you? "

    Unfortunately I don't use docker, I'm on a different system that is Apache and PHP.

    I can try to see here if someone of UVdesk are able to install UVdesk using docker-compose.

    Please check your email address as you should have received an email that invite to verify your forum email address.
    Also please try to login here in the community and let me know you can read and reply to this topic created for you.

    Here is your first support message in GitHub


  • mod admin

    Hi, I'm marking this topic as resolved as you mention here, seems you was able to install UVdesk.


  • mod admin

    @ericastillo I'm sorry to know you are facing issues with the installation of UVdesk using docker-compose.
    Have you try to ask help about docker-compose?
    https://docs.docker.com/compose/#getting-help

    You can also maybe ask on https://stackoverflow.com/

    A video of what you do and about the issue faced can be useful.
    Be sure to not include sensible data.
    I seen what the issue is but I don't know docker-compose right now so maybe you need show the issue to others.
    You can create a good video as a GIF for example using the open-source https://www.screentogif.com/

    Here we can try to ask to the UVdesk team if they know about some issue installing UVdesk using docker-compose.
    Have you tried to install other application different to UVdesk?
    If so you faced the same database issue?

    I see you are using Mysql 8.0 and PHP 7.2



  • First I want to thank you for your time and intention to help me. Thanks for that.

    On the other hand, I share that I am also learning about Docker-Compose, actually I have seen that it is very practical using this system since we can use microservices installed by other people. Example apache and php can come already configured in a centos or ubuntu and I just download the image, actually that is what I am doing. The docker-compose that I generate is based on the code of a person who shared it in Hub-Docker, https://hub.docker.com/r/nuttcorp/uvdesk, there is another person who also shares it https: // hub. docker.com/r/dietermartens/uvdesk, in my case I make adjustments to what I need. However, there is that detail that it does not connect to the Database, but it is only from the browser, because if I use an application to access the database if it enters. So I think it is the connection of PHP with MySQL. Previously in UVDESK they told me that it was likely that the Redis PHP extension was missing, however I did not know how to configure it. I hope someone can help me. Thanks.


  • mod admin

    @ericastillo as I told I never know docker-compose usage so I will be unable to help you with docker-compose usage or issues. This is the first important point to understand.

    Me but I think also UVdesk team can try to help you if you have an issue that is only present with UVdesk and not with maybe your server configuration or docker-compose.

    Consider UVdesk is a software provided for free by the UVdesk team, this means a lot of work done for free who can live maybe thanks to donations that users or especially business company can also do.
    this is my point of view, I'm not part of the UVdesk team. I'm just a passionate UVdesk user that take care about helping in the forum and on GitHub on my free time.

    The UVdesk team can be busy with work that is not just the open source project so if an issue never is about UVdesk but about server configuration or docker-compose the team cannot look into this, maybe I think not for free.

    In my UVdek help desk install I used to download the original UVdesk version from GitHub or using composer.
    Looks maybe the package you use on docker-compose are forked by different users?

    You linked two different UVdesk resources.
    Have you tried to ask help on the relative GitHub pages of who is releasing this packages?

    Previously in UVDESK they told me that it was likely that the Redis PHP extension was missing, however I did not know how to configure it. I hope someone can help me. Thanks.

    I suppose this is not something UVdesk team can manage in support requests.

    If you have issue on using the self-hosted version have you consider the hosted version?
    https://www.uvdesk.com/en/pricing/

    Also maybe consider you can try to do some Google research about how to resolve issues with PHP and Mysql connections and about installation of extensions.

    It's not I don't wanna help you, I'm unable too.
    I'm just trying to give to you useful informations hoping someone of that can help you more to reach the right steps to resolve your installation issues.



  • I really appreciate your help in trying to help and guide me. Blessings for you. Thanks.


  • mod admin

    @ericastillo Erika, it's a pleasure for me and I want to see you and your business use UVdesk!
    It's a nice help desk system, I like it and I see is madding improvement with time.
    Uvdesk has a nice look and it's responsive.

    I hope some links or suggestion I given to you will help you to made the installation successfully.


  • mod admin

    Hi, I'm marking this topic as resolved as you mention here, seems you was able to install UVdesk.


Log in to reply