[Issue - strong -] Cannot have hidden department. Replies from Agent to Customer missed.



  • Hi, recently i discover UVdesk never send email to "customer" when an agent made a reply. This is very bad and is something that should be not happen also because there is no signal for operator or admin that let "staff" beside the ticket, know the replies are not sent.

    The issue is created because I need to have some department invisible to the user front end drop down menu so I fund the only way to do this is disable the department.

    If the department is disabled simply replies email are not sent.
    Again this is very bad. You should disable reply in ticket if you want do so and add an option to hide some department from the drop down menu.

    At the moment seems I cannot have hidden department.
    Need a solution for this also I think is a big issue let replies to users to be not sent to customer if department is disabled.

    What the disable function are meant for?

    Another thing I cannot understand is why I'm able to configure MailBox with different SMTP than I'M unable to see email from the live chat department go out from the live chat email address.

    I don't wanna have all outgoing email out from just one email address.
    Seems in UVdesk all is ready for support different department and email but is not. Seems you can support different email address for incoming email but unable to reply from the department email.

    I may have a live chat ticket department that should be not visible in the drop down interface menu.
    Also I may have another department for another external website that should be internal for ticket email only but if disable a department disable also notification to the users about Agent reply... this sound to be impossible to use.

    Actually because of this issue, if I want continue to provide ticket and replies I'm forced to show that private department. It's a big issue and not nice on interface side.

    As you can see in the below image I need have public department and private department.
    The green one is visible from the interface to the users but the red one should be active but invisible get support only by email.

    alt text

    In UVdesk I cannot hide this department or if I disable it agents will be able to reply, to think the user has received the reply but is not.

    Solutions?

    https://github.com/uvdesk/community-skeleton/issues/323



  • Seems all replies from an Agent to the customer are broken.
    When operator send a message to the user the confirmation message is in English also if I'm in the web interface Italian.

    Seems like some issue has turned the ticket system in tilt... something that should not happen.
    I have no idea why user get only welcome registration email and no other replies email even if the department is active.

    The situation is strange.
    With ticket opened online no issue.
    With ticket by email reply are not arriving even if assigned to group, operator and team.
    Seems when I post a reply the green message is not translated not only on my Help Desk.

    Now I'm doing tests for understand what is broken... but the fact no error on agent console and "customer" did not get any email broke my trust on the Help Desk.



  • Issue was and is related to email with special characters: https://github.com/uvdesk/community-skeleton/issues/325
    The issue about disabled department was closed also if still be a small issue: operator cannot create ticket if department is disabled.

    Closed issue: https://github.com/uvdesk/community-skeleton/issues/323


Log in to reply